Diagram-uap-edit

Drawing-DHCP 43-edit

ปกติแล้วถ้าเราจะปรับเปลี่ยน config หรือตรวจสอบการทำงานของ Access Point เราจะต้องทำผ่าน Software unifi controller ที่ติดตั้งไว้ที่คอมพิวเตอร์เครื่องใดเครื่องหนึ่ง ที่อยู่ที่ site งานหากคอมพิวเตอร์เครื่องนั้น ใช้งานไม่ได้ด้วยสาเหตุไหนก็ตาม จะทำให้เราไม่สามารถจัดการกับ access point ของเราได้เลย และในกรณีที่เรามีหลายๆ site และต้องการระบบจัดการ access point แบบรวมศูนย์ก็จะไม่สามารถทำได้ เนื่องจากจะต้องติดตั้ง software ลงที่คอมพิวเตอร์ ที่ตั้งอยู่ของ site นั้นๆ และจะสามารถจัดการเฉพาะ access point ที่ติดตั้งอยู่ที่ site นั้นๆ เท่านั้น ส่งผลให้ไม่สะดวกกับการจัดการ ดังนั้นจึงเป็นที่มาของ solution นี้ ซึ่งเป็นระบบการจัดการแบบ Centralize

โดยข้อดีของระบบ Centralize UniFi Controller Software
1. ไม่จำเป็นต้องมี server หรือ PC ที่ต้องติดตั้ง Software Unifi Controller ไว้ที site งาน ตลอดเวลา  ให้ประหยัดค่าใช่้จายในการลงทุนหา server หรือ PC
2. ในกรณีที่มี โรงแรมสาขา สามารถบริหารจัดการ Access Point โดยแยกเป็นแต่ละ site ได้ และสามารถจัดการจาก server เพียงตัวเดียว จะสามารถมองเห็นทุกๆ site งาน ทำให้สะดวกสำหรับผู้ดูแลระบบ
3. ทำงานอยู่บน server บน cloud มีเสถียรภาพที่สูงและสามารถเข้าใช้งานผ่านทาง web management ได้จากทุกที่ เพราะเป็น server ที่ตั้งอยู่บน cloud

Key Concept
1.Layer 3 Management
ปกติการคุยกันระหว่าง access point หรือ software จะติดต่อกันได้ผ่านทาง layer 2 หรือ Layer 3
Layer 2 คือตัว access point กับ controller อยู่ใน broadcast domain เดียวกัน
Layer 3 คือตัว access point กับ controller ไม่จำเป็นอยู่ใน broadcast domain เดียวกัน ขอแค่ติดต่อหากันได้ (สามารถ ping เจอกัน) หมายความว่า IP Management ของ access point จะต้องสามารถติดต่อกับ UniFi Controller Software on cloud ได้ผ่าน routing protocol

2.DHCP Option 43
DHCP Server คือ server ที่ทำหน้าที่แจก ip ให้กับเครือง client หรือ device ต่างๆที่ส่ง request มาเพื่อรับ ip ไปใช้งาน โดยปกติแล้ว ค่า attribute ที่แจกไปใหกับ Client ก็จะมีค่าพื้นฐานเช่น IP addess,Subnet mask,Gateway,DNS ซึงเท่านี้ก็จะเพียงพอต่อการใช้งานแล้ว แต่ในความเป็นจริงแล้ว เราสามารถส่งค่า attribute พิเศษที่เราต้องการส่งไปใน client เพิ่มมาได้ โดย attribute หนึ่งที่มีความสำคัญและถูกนำมาใช้ ในระบบ enterprise network ก็คือ DHCP Option 43 ซึ่งระบบแบบนี้จะสามารถนำมาใช้กับอุปกรณ์ access point (manage access point )ที่สามารถทำงานร่วมกับ hardware/Software controller ได้ เช่น CISCO Aironet ทำงานร่วมกับ Wireless controller หรือ ในที่้นี้ก็จะเป็น UAP ทำงานร่วมกับ Software Unifi Controller

โดยหลักการทำงานคือ เวลาที่ access point จะถูก manage จาก controller ได้ มันจะต้องทราบก่อนว่าจะต้องวิ่งไป join กับ controller ตัวไหน แล้วหลังจากนั้นเมื่อมันทราบ ip ของ controller มันก็จะวิ่งเข้าไป connect โดยฝั่ง controller ก็จะเห็น AP โผล่ขึ้นมาที่ console พร้อมกับทำการ approve เพือให้จัดการ AP ตัวนั้นๆได้

ซึ่งการที่ AP จะรู้ว่า IP ADDRESS ของ controller คือ ip อะไรเราก็สามารถทำได้ 2 วิธี คือ Manual หรือ Automatic ซึ่งวิธีแรกแบบ manual ก็คือไป run command ที่ AP ตัวนั้นๆ เพื่อระบุ ip ของ controller แต่วิธีที่ง่ายกว่าและสะดวกกว่าคือ การที่เราแจก attribite DHCP option 43 ไปให้ AP เลย (โดยทั้งนี้ IP Management ของ Access Point จะต้องเป็นแบบรับ DHCP) โดยใน กระบวนการนี้ DHCP Server จะส่งค่า IP ของ controller ไปให้ AP ทันทีเลย ทำให้ AP สามารถทราบได้ทันทีว่าต้องวิ่งไปคุย controller ที่ IP อะไร ดังนั้นจะเห็นว่า การทำวิธีนี้จะทำให้ admin ลดขั้นตอนการทำงานที่ต้องเข้าไป manual ระบุ ip controller ให้กับ AP ทุกตัว

โดยสำหรับในกรณีที่เราใช้งาน Mikrotik + UAP เราสามารถทำให้ Mikrotik เป็น DHCP Server เพื่อแจก IP และ Option 43 ไปยัง UAP ได้ โดยทำการ config ดังนี้

/ip dhcp-server option add code=43 name=unifi value=0x0104C0A8030A
/ip dhcp-server network set 0 dhcp-option=unifi

โดยค่า value ที่ใส่จะต้องแปลง IP ของ controller เป็นเลขฐาน 16 ก่อน
ยกตัวอย่างในที่นี้ C0A8030A คือ 192.168.3.10 ในเลขฐานสิบ

ลองศึกษาเพิ่มเติมกันดูนะครับ
Credit:
https://help.ubnt.com/hc/en-us/articles/204909754-UniFi-Layer-3-methods-for-UAP-adoption-and-management

DIY Cloud-Hosting a Ubiquiti (UBNT) UniFi Controller


Leave a Reply

Your email address will not be published. Required fields are marked *